Tutorials → Install Intel drivers on Linux…

Install Intel Drivers on Linux Mint

When trying to run the "Intel Graphics Installer for Linux" from 01.org on Linux Mint there will be a message saying your operating system is not supported.

Here is how to fix that:
In console type
sudo gedit /etc/lsb-release
Then edit the content from
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=17
DISTRIB_CODENAME=qiana
DISTRIB_DESCRIPTION="Linux Mint 17 Qiana"
to
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Linux Mint 17 Qiana"
and save, but don't close the editor!

Then start the installer again and after the installation finishes, change the file content back to original (Ctrl+Z) and save. The lsb-release file will be replaced on boot time so you have to manipulate it everytime you run this installer.

At last you have to add the 01.org key because otherwise your linux update manager will throw an error:
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | sudo apt-key add -
wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O - | sudo apt-key add -
sudo apt-get update

Chuck Norris kann bei Yahoo googeln.